pabadger
Civilian
Posts: 3
Joined: Fri May 09, 2014 4:47 am

Battles run very slowly

Fri May 09, 2014 5:09 am

Hello,
I recently bought AACW. No problems installing or updating to 1.17. The game seemed to run fine until there was a battle. Then it would hang. I browsed the forums and learned that running it in compatibility (WinXPSP2) mode helps. It does. Now instead of hanging on a battle every battle takes between 5-20 minutes. The hard drive runs the whole time. This can't be normal, correct? Is this a known issue? I would really like to play this game, but as is I don't think I will be able to.


My computer is an
HP p6404y
AMD Phenom II X4 820 2.8 processor
8 GB ram
Win7 SP1 (64bit)
ATI Radeon 6850HD 1GB

Thank You

User avatar
Pocus
Posts: 24759
Joined: Wed Oct 19, 2005 7:37 am
Location: Lyon (France)

Fri May 09, 2014 1:52 pm

The logging frequency is probably too high for your hard disk (or the controls done on each writing by an anti-virus etc.). If you know where the game is installed, open ACW\Settings\general.opt with a text editor, and look at the line named
LogBatch =

Change the value here to 100.
Image


Hofstadter's Law: "It always takes longer than you expect, even when you take into account Hofstadter's law."

pabadger
Civilian
Posts: 3
Joined: Fri May 09, 2014 4:47 am

Sat May 10, 2014 4:46 am

Thank you for your quick response. I opened general.opt and discovered that Logbatch was already at 100. I ran one turn of the Shiloh scenario. As expected no change in behavior. 4 battles took about an hour to process, again with the hard drive light on the whole time.

Edit: spelling

User avatar
Pocus
Posts: 24759
Joined: Wed Oct 19, 2005 7:37 am
Location: Lyon (France)

Mon May 12, 2014 9:18 am

And the hard drive on which the game is, has several GB free and is not too fragmented?

You can plug off the Internet and disable your anti-virus and any security suite perhaps and see if it runs faster, if yes, you got your culprit.
Image


Hofstadter's Law: "It always takes longer than you expect, even when you take into account Hofstadter's law."

pabadger
Civilian
Posts: 3
Joined: Fri May 09, 2014 4:47 am

Wed May 14, 2014 12:50 am

I disconnected the internet and turned off my security suite. That did the trick! Battles run very quickly now. Thank You for your help.

Return to “AACW Technical support / Aide technique”

Who is online

Users browsing this forum: No registered users and 2 guests