grumblefish
Civilian
Posts: 3
Joined: Tue Mar 25, 2008 10:33 pm

Patch ruins install (gamersgate)

Tue Mar 25, 2008 10:38 pm

Hello Everybody,

I tried posting this at the paradox forums (which deal with gamersgate), but unfortunately nobody has been able to solve this problem so far. Basically, I install BoA from Gamersgate (v1.07), and then install the 1.13d patch (downloaded from this forum). I have tried this multiple times (sometimes playing the game, then installing), and everytime it corrupts my install so that the game crashes when I try to load it.

Here is the error message I receive while installing the patch (the only way to continue the installation is to press "ignore"):


"C:\games\birth of america\boa\gamedata\models\261AME Philippe Sacr?mdl

An error occurred whiel trying to rename a file in the destination directory:
MoveFile failed; code 123.
The filename, directory name, or volume label syntax is incorrect.

Click Retry to try again, Ignore to skip this file (not recommended), or Abort to cancel installation"

I have no idea how to solve this problem. I like the game, but I'd prefer to play it with the latest patch, and am therefore waiting until the issue is resolved before I begin a new campaign (unfortunately, that wait has lasted a week so far).

User avatar
Rafiki
Posts: 5811
Joined: Thu Aug 24, 2006 9:19 am
Location: Oslo, Norway

Tue Mar 25, 2008 10:51 pm

Hi grumblefish, and welcome to the forums :)

Sorry that you're having problems with the patch. From the looks of it, I'd say it has to do with non-Ascii letters in the file name (and the inability of the computer to deal with them).

It's a problem I've seen a few others here have, but I don't recall right now what the solution has been. I'll go and see if I can find something about it. Rest assured, I'll be very surprised if we don't have this sorted out in a lot less than a week :)
[CENTER]Latest patches: AACW :: NCP :: WIA :: ROP :: RUS :: PON :: AJE
Visit AGEWiki - your increasingly comprehensive source for information about AGE games
[SIGPIC][/SIGPIC]
[/CENTER]

User avatar
lodilefty
Posts: 7372
Joined: Sat Aug 11, 2007 3:27 pm
Location: Finger Lakes, NY GMT -5 US Eastern

Tue Mar 25, 2008 10:55 pm

Interesting. That model is actually named
261AME Philippe Sacr[color="Red"]é[/color].mdl

but is not the only model file with the accent....

Looks like your system doesn't like that character immediately before the ".mdl"....

If it isn't properly reading the model name, it may be creating an erroneous or duplicate UID 261.

You could look in BoA\GameData\Models for two files starting with 261. Should only be one.....

[I'm just trying to point this out. I'm not a system expert! :siffle: ]
Always ask yourself: "Am I part of the Solution?" If you aren't, then you are part of the Problem!
[CENTER][/CENTER]
[CENTER]Visit AGEWiki - your increasingly comprehensive source for information about AGE games[/CENTER]

[CENTER]Rules for new members[/CENTER]
[CENTER]Forum Rules[/CENTER]

[CENTER]Help desk: support@slitherine.co.uk[/CENTER]

User avatar
Rafiki
Posts: 5811
Joined: Thu Aug 24, 2006 9:19 am
Location: Oslo, Norway

Tue Mar 25, 2008 11:01 pm

Looking at other reports alon the same lines, it seems that especially Asian versions of Windows have a problem with filenames with accented characters. I know that such names are no longer present in newer versions of AACW and NCP, but I'm not sure what the status is for BoA.

If you don't get an answer here with a day, I recommend mailing support@ageod.com with information about your purchase and containing the info you provided in your first post.
[CENTER]Latest patches: AACW :: NCP :: WIA :: ROP :: RUS :: PON :: AJE

Visit AGEWiki - your increasingly comprehensive source for information about AGE games

[SIGPIC][/SIGPIC]

[/CENTER]

User avatar
lodilefty
Posts: 7372
Joined: Sat Aug 11, 2007 3:27 pm
Location: Finger Lakes, NY GMT -5 US Eastern

Tue Mar 25, 2008 11:08 pm

The crash may be a 'duplicate UID'. [Two files trying to define the same model]

You can TRY this:

Look in your Birth of America\BoA\GameData\Models folder

Scroll down to find [color="Red"]261AME Philippe Sacré.mdl [/color][or any file starting with 261]...

If there are two, delete the 'older one', and be sure the one remaining looks something like
261AME Philippe Sacré.mdl or
261AME Philippe Sacre.mdl

Believe it or not, the actual file name doesn't matter, just that there is only one [not two, not zero!!] :sourcil:

Good luck! BoA is worth the effort to fix this! :nuts:
Always ask yourself: "Am I part of the Solution?" If you aren't, then you are part of the Problem!
[CENTER][/CENTER]

[CENTER]Visit AGEWiki - your increasingly comprehensive source for information about AGE games[/CENTER]



[CENTER]Rules for new members[/CENTER]

[CENTER]Forum Rules[/CENTER]



[CENTER]Help desk: support@slitherine.co.uk[/CENTER]

User avatar
Rafiki
Posts: 5811
Joined: Thu Aug 24, 2006 9:19 am
Location: Oslo, Norway

Tue Mar 25, 2008 11:11 pm

I'd aim for removing the one containing "é" in the filename, since I imagine that's the one causing problems :)

(Though, rather than deleting, simply move away, in order to not do anything irreversible at this point)
[CENTER]Latest patches: AACW :: NCP :: WIA :: ROP :: RUS :: PON :: AJE

Visit AGEWiki - your increasingly comprehensive source for information about AGE games

[SIGPIC][/SIGPIC]

[/CENTER]

User avatar
lodilefty
Posts: 7372
Joined: Sat Aug 11, 2007 3:27 pm
Location: Finger Lakes, NY GMT -5 US Eastern

Wed Mar 26, 2008 12:05 am

Rafiki wrote:I'd aim for removing the one containing "é" in the filename, since I imagine that's the one causing problems :)

(Though, rather than deleting, simply move away, in order to not do anything irreversible at this point)


In my install, the "é" works fine [but I'm running North American system :innocent: ]. You can simply rename the file if that helps, too. It's the unique content of the file that matters. ...and it's file name probably needs to end with ".mdl"
Always ask yourself: "Am I part of the Solution?" If you aren't, then you are part of the Problem!
[CENTER][/CENTER]

[CENTER]Visit AGEWiki - your increasingly comprehensive source for information about AGE games[/CENTER]



[CENTER]Rules for new members[/CENTER]

[CENTER]Forum Rules[/CENTER]



[CENTER]Help desk: support@slitherine.co.uk[/CENTER]

FM WarB
Colonel
Posts: 337
Joined: Thu Feb 28, 2008 8:19 pm

Wed Mar 26, 2008 12:32 am

I suspected this was why in the Events file Quebec (I dont have that accent for the e) is Kebec. I am shifting Gentleman Johnny's reinforcement location...

tagwyn
AGEod Guard of Honor
Posts: 1220
Joined: Tue Apr 17, 2007 4:09 pm

Wed Mar 26, 2008 7:28 am

RAfe: I have tried to buy three smaller games from Gamersgate and succeeded in their taking my money but I have been unable to download any of them!!!! They have no idea of what the problems might be. These games are not available in hard copy. :p apy:

User avatar
Rafiki
Posts: 5811
Joined: Thu Aug 24, 2006 9:19 am
Location: Oslo, Norway

Wed Mar 26, 2008 9:44 am

Sorry to hear that Tag. I have only bought one game from Gamer's Gate, myself (in fact, it was BoA), and had no problems downloading it by using the Gamer's Gate client.
[CENTER]Latest patches: AACW :: NCP :: WIA :: ROP :: RUS :: PON :: AJE

Visit AGEWiki - your increasingly comprehensive source for information about AGE games

[SIGPIC][/SIGPIC]

[/CENTER]

grumblefish
Civilian
Posts: 3
Joined: Tue Mar 25, 2008 10:33 pm

Wed Mar 26, 2008 8:18 pm

lodilefty wrote:The crash may be a 'duplicate UID'. [Two files trying to define the same model]

You can TRY this:

Look in your Birth of America\BoA\GameData\Models folder

Scroll down to find [color="Red"]261AME Philippe Sacré.mdl [/color][or any file starting with 261]...

If there are two, delete the 'older one', and be sure the one remaining looks something like
261AME Philippe Sacré.mdl or
261AME Philippe Sacre.mdl

Believe it or not, the actual file name doesn't matter, just that there is only one [not two, not zero!!] :sourcil:

Good luck! BoA is worth the effort to fix this! :nuts:


Sorry, that doesn't work for me.

Before I install the 1.13d patch, here is what I see:

One file named "261AME Philippe Sacre.mdl"
Thus, at this stage, I cannot delete anything.

After I install the 1.13d patch (clicking ignore, because I must):

No files beginning with 261 at all; the file is gone completely.
Thus, I still cannot delete anything.

The installer also has a problem with the following file:

\gamedata\units\303AME Philippe Sacre?uni


Seriously, I have no idea what is wrong. These two files are the only ones that hinder the patch process, but they are enough to ruin the game.

User avatar
arsan
Posts: 6212
Joined: Tue Nov 28, 2006 6:35 pm
Location: Madrid, Spain

Wed Mar 26, 2008 8:31 pm

Hi
I attach here the two files your installation is missing.
Maybe you can manually add them and the game will work :bonk:
Hope it helps
Regards!
Attachments
sacre files.rar
(884 Bytes) Downloaded 154 times

grumblefish
Civilian
Posts: 3
Joined: Tue Mar 25, 2008 10:33 pm

Thu Mar 27, 2008 1:31 am

Success! Thanks Arson, and everybody else who helped out! :niark:

User avatar
arsan
Posts: 6212
Joined: Tue Nov 28, 2006 6:35 pm
Location: Madrid, Spain

Thu Mar 27, 2008 9:58 am

Glad it helped! Hope you enjoy the game!
Regards!

User avatar
Pocus
Posts: 24756
Joined: Wed Oct 19, 2005 7:37 am
Location: Lyon (France)

Thu Mar 27, 2008 11:27 am

Great move from Arsan! :coeurs:
Image


Hofstadter's Law: "It always takes longer than you expect, even when you take into account Hofstadter's law."

Kuan
Civilian
Posts: 2
Joined: Sat Jan 21, 2012 1:31 pm

Sat Jan 21, 2012 3:41 pm

arsan wrote:Hi
I attach here the two files your installation is missing.
Maybe you can manually add them and the game will work :bonk:
Hope it helps
Regards!


That's everything I needed. The game now works wonderfully. Thanks a lot! :thumbsup:

Return to “BoA Technical support / Aide technique”

Who is online

Users browsing this forum: No registered users and 1 guest