pmarshall
Civilian
Posts: 2
Joined: Mon Mar 06, 2006 1:00 pm

Failed to Initialize DirectX Audio

Mon Mar 06, 2006 1:06 pm

Whenever I try and run my fresh install of BoA, it crashes with the Following error.

Failed to initialize DirectX Audio. DirectX 8 may not be installed.

However, when I ran DXDiag, the soundcard passed all of the DirectSound tests.

The log file contains:
12:02:11 (Reporting) User: p.marshall Computer: DEV-MARSHALL IP: **********
12:02:11 (Reporting) USettings.LoadSettings 34 settings loaded, out of 2 settings files.
12:02:12 (Reporting) ULocalize.LoadLocalStrings: System local strings loaded from C:\Program Files\Birth of America\BoA\Settings\LocalStrings_BOA.csv
12:02:12 (Reporting) TAbiDefs.Create 35 Abilities loaded, out of 35 abilities files.
12:02:12 (Reporting) TTerrainDefs.Create 24 Terrains definitions loaded, out of 305 terrains files.
12:02:14 (Reporting) TListModels.Create 255 models loaded, out of 255 models files.
12:02:14 (Reporting) TStrucDefs.LoadFromFile 5 StrucDef loaded, out of 5 StrucDef files.
12:02:14 (Reporting) TFactionDefs.LoadFromFile 4 FactionDef loaded, out of 4 FactionDef files.
12:02:14 (Reporting) Application.Initialize OK
12:02:14 (Reporting) TSplash.Create OK
12:02:14 (Reporting) TSplash.Show OK
12:02:14 (Reporting) TSplash.Repaint OK
12:02:27 --- End of Log ---

One thing I have noticed, is that the installer appears to install one DirectX 8 Dll into the Application directory DX3D881AB.dll, but my OS has directX 9.0a installed.


Any help would be appreciated.

User avatar
Pocus
Posts: 25160
Joined: Wed Oct 19, 2005 7:37 am
Location: Lyon (France)

Mon Mar 06, 2006 1:36 pm

Hi,

BoA use DirectX 8, which is supported by DirectX 9. The sounds are played with DirectShow not DirectSound though. Dont hesitate to send me at support@ageod.com your DxDiag so I can check your config myself.

Also update to the latest DirectX 9 version (which is 9.0c if I recall well)

Try to do the following, so you can play BoA while we works on the problem (but without sounds):

in the folder Birth of America\Boa\Settings there is a file name general.opt
open it with notepad or any text reader

change the 2 first entries to:
1. *** Sound media options ***
LoadSounds = 0
PlayMusic = 0

Thanks for your patience,
Image


Hofstadter's Law: "It always takes longer than you expect, even when you take into account Hofstadter's law."

pmarshall
Civilian
Posts: 2
Joined: Mon Mar 06, 2006 1:00 pm

Mon Mar 06, 2006 2:12 pm

I have tried setting the sounds to 0 in the General.opt - with no joy, the game still crashes at the same point.

I have uploaded my DxDiag file, which may help. I beleive the problem may be with the Bluetooth adaptor, which is regestering within DirectX as a second audio device.

Peter
Attachments

[The extension txt has been deactivated and can no longer be displayed.]


User avatar
Pocus
Posts: 25160
Joined: Wed Oct 19, 2005 7:37 am
Location: Lyon (France)

Mon Mar 06, 2006 2:27 pm

The message that you got is triggered by DirectMusic failing to initialize. This is confirmed by your DxDiag file which is unable to list DirectMusic ports. Perhaps you can fiddle with your bluetooth device so that its your real audio card (100% Dx compliant) which is registered?

I can produce a BoA executable which can run without DirectMusic ... but you wont get any sounds. send me your email address at [email="support@ageod.com"]support@ageod.com[/email] if you want to get it before the next patch.

I'm really sorry, but I dont think I can do much more for you for now. It is planned to move to another DirectX library somehow, but this wont be done in march I fear.
Image


Hofstadter's Law: "It always takes longer than you expect, even when you take into account Hofstadter's law."

Return to “BoA Technical support / Aide technique”

Who is online

Users browsing this forum: No registered users and 7 guests