AlphaBeta
Civilian
Posts: 4
Joined: Sat May 07, 2016 10:03 pm

Do I need to install the latest patch?

Sat May 07, 2016 10:25 pm

I bought TYW a week ago - I downloaded the file from matrixgames.com - and I have it up and running on my PC. I understand from this forum that the latest patch was released a few weeks ago (TYW patch 1.02RC made available on March 11). Do I need to install that patch or am I playing with the latest version of the game?

Thank you for your help.

User avatar
Ebbingford
Posts: 6030
Joined: Sun Oct 14, 2007 5:22 pm
Location: England

Sat May 07, 2016 10:44 pm

Install the patch :thumbsup:
"Umbrellas will not be opened in the presence of the enemy." Duke of Wellington before the Battle of Waterloo, 1815.

"Top hats will not be worn in the Eighth Army" Field-Marshal Viscount Montgomery of Alamein K.G.


Image

Return to “TYW Technical support / Aide technique”

Who is online

Users browsing this forum: No registered users and 1 guest