Page 1 of 1

RGD Icons for Conversion switched

Posted: Fri Apr 08, 2016 4:13 am
by elxaime
Using Windows 10, started a new PBEM of the grand campaign under 102 RC1. Both sides did a fresh install of the game, then patched. There was a lot of the same weirdness as the other threads as far as placement of the game files. I had a hard disc I had purchased from AGEOD with version 1.0. It puts the game files in C:/Games. The 102 RC1 patch from the Slitherine site, meanwhile, puts the game files in C:/Program Files (x86)/Matrix Games/Thirty Years War. Managed to get that straightened out finally (I think) and got the game started. I had to hunt for the saved game file folder, but finally found it in C:/temp/AGE.

Someone really needs to do a pass through the install/patch to have things sent to the right folders.

Anyway, as Protestants, when I started the first turn, the RGD for religious conversion shows as "Convert to Catholics." The RGD otherwise seems OK as far as placement. Looks like the icons got switched somehow. It may/may not have something to do with the mess caused by installations putting the game in different places, but not sure.

The game worked fine under version 1.00. The problems all cropped up when we tried to update. The double Bucquoy problem from the other thread also came up, but my opponent reported that already.

Posted: Fri Apr 08, 2016 10:40 am
by Leibst
Its clear an issue of bad installation.
In fact its easy, the game has a TYW folder, when you install the patch just be sure of overwritting there, in the TYW folder and all the new files will get into their proper place.
Update will work fine once the patch became official.

File sent

Posted: Mon Apr 11, 2016 2:16 am
by elxaime
We both did a clean wipe and full re-install, but for me same problem. Here is the file:

Posted: Mon Apr 11, 2016 8:10 pm
by Leibst
For me its ok your saved game, im sure you have an issue with the installation of the patch.
Let me show you my TYW folders in one of the installations i have.
The Folder called TYW is where you have to install the patch, overwritting its files there.
It seems to me that you have the old and the new files regarding the RGD, and the same issue for the units and models in the GameData Folder.

Posted: Tue Apr 12, 2016 12:19 am
by elxaime
Well, it is a mystery. Perhaps it is related to the fact I use Windows 10. When I do a fresh install of version 1.0, it tries to put the game into C:\Program Files (x86)\Matrix Games. When I try to install the patch, it tries to put the patch into C:\Games (which is where all my other AGEOD games typically go). But no matter which folder or sub-folder I try to install the patch in, it always creates a set of folders called "Thirty Years War" with a "TYW" sub-folder. The Thirty Years war folder and TYW sub-folder are always created, regardless of whether I install into the "Games" folder, the "Thirty Years War" folder or the "TYW" subfolder. They sit alongside each other and I have to manually drag the new files onto the old. Then - and only then - do I get the message prompting me to overwrite files - it never happens during the actual installation, only when I manually try to copy the new over the old.

Again, maybe it is Windows 10 related, since it seems you are using Windows 7 and I know there have been issues related to how Windows 10 places things. Anyway, I have done about ten uninstalls and fresh installs, and no solution - I am always getting messed up RGD conversion icons, sometimes multiple Contribution icons as well.

I am checking with Slitherine Help Desk to see if I am missing something. I will report back what I find.

EDIT - we seem OK now. My opponent restarted and it works fine. Must have been a corrupt file he sent me.