TempestVVV
Private
Posts: 20
Joined: Mon Aug 17, 2015 7:07 am

Problem with BoR 1.04 patch-extraction and updating

Mon Aug 17, 2015 7:37 am

Having problems getting the 1.04 patch to extract or even update the Birth of Rome game I downloaded from Matrix today.
The updater downloads a the 1.04 patch-but it doesn't apply because in the game start UI corner it says 1.02.
When I checked inside the main game folder I found in a file named PATCHES
the 1.04 patch -but I get an error message when I run the exe. (I've run the exe in the patch file and outside the game and get same result)

[ATTACH]34400[/ATTACH]

And every time I repeat running the patch it also says the game is updated. But the 1.02 in the corner at game start says otherwise.

So I tried downloading the patch separately and All 1.04 patches I downloaded from Matrix, AGEOD and a link provided in the Slitherine forum for a ZIP and WinRar packed 1.04 patches resulted in me downloading compressed 1.04 that [color="#FF0000"]will NOT extract[/color].
I used Explorer, WinRar and 7gZ and none of them can get the 1.04 file out of compression.

I have Espana 1936 game, and Revolution under Siege Demo and Alea Jacta Este Demo and have had NO problems with updating or running the AGEOD engine (full game or demo) or updating Espana 1936 through Matrix (or any other non AGEOD games from Matrix).

So the sum total. The patch I have unextracted will not decompress and all zip file patches appeared corrupted.

I'm running a Win 7 machine.
Can you help?

The Birth of Rome update log reads as follows.

[08/16/2015 19:01:48] Success Update started: B:\Matrix Games\Birth of Rome\update.exe
[08/16/2015 19:01:48] Notice Update engine version: 3.0.0.0
[08/16/2015 19:01:48] Notice Product: Birth of Rome, version %ProductVer%
[08/16/2015 19:01:48] Success Language set: Primary = 9, Secondary = 1
[08/16/2015 19:01:48] Success Include script: _TU20_Global_Functions.lua
[08/16/2015 19:01:48] Success Display screen: Welcome
[08/16/2015 19:01:49] Success Display screen: Download Server Script
[08/16/2015 19:02:02] Success Language set: Primary = 9, Secondary = 1
[08/16/2015 19:02:02] Notice Automatic update required.
[08/16/2015 19:02:28] Notice Restarting update executable: 'B:\Matrix Games\Birth of Rome\BoR.ts3'
[08/16/2015 19:02:28] Notice Dat file updated: 'B:\Matrix Games\Birth of Rome\update.dat'
[08/16/2015 19:02:28] Success Run client data event: Client Script
[08/16/2015 19:02:28] Notice Exit update process (Return code: 5)
[08/16/2015 19:02:29] Success Update started: B:\Matrix Games\Birth of Rome\update.exe
[08/16/2015 19:02:29] Notice Update engine version: 3.7.0.0
[08/16/2015 19:02:29] Notice Product: Birth of Rome
[08/16/2015 19:02:29] Success Language set: Primary = 9, Secondary = 1
[08/16/2015 19:02:29] Success Include script: _TU20_Global_Functions.lua
[08/16/2015 19:02:29] Success Display screen: Download Server Script
[08/16/2015 19:02:35] Success Language set: Primary = 9, Secondary = 1
[08/16/2015 19:02:35] Success Display screen: Update Available
[08/16/2015 19:02:39] Success Display screen: Download File (FTP)
[08/16/2015 19:20:19] Success Display screen: Update Finished
[08/16/2015 19:20:22] Success Run client data event: Client Script
[08/16/2015 19:20:22] Notice Exit update process (Return code: 0)
[08/16/2015 19:34:28] Success Update started: B:\Matrix Games\Birth of Rome\update.exe
[08/16/2015 19:34:28] Notice Update engine version: 3.7.0.0
[08/16/2015 19:34:28] Notice Product: Birth of Rome
[08/16/2015 19:34:28] Success Language set: Primary = 9, Secondary = 1
[08/16/2015 19:34:28] Success Include script: _TU20_Global_Functions.lua
[08/16/2015 19:34:28] Success Display screen: Welcome
[08/16/2015 19:34:30] Success Display screen: Download Server Script
[08/16/2015 19:34:37] Success Language set: Primary = 9, Secondary = 1
[08/16/2015 19:34:37] Success Display screen: Already At Target
[08/16/2015 19:34:42] Success Run client data event: Client Script
[08/16/2015 19:34:42] Notice Exit update process (Return code: 5)
[08/16/2015 19:59:35] Success Update started: B:\Matrix Games\Birth of Rome\update.exe
[08/16/2015 19:59:35] Notice Update engine version: 3.7.0.0
[08/16/2015 19:59:35] Notice Product: Birth of Rome
[08/16/2015 19:59:35] Success Language set: Primary = 9, Secondary = 1
[08/16/2015 19:59:35] Success Include script: _TU20_Global_Functions.lua
[08/16/2015 19:59:35] Success Display screen: Welcome
[08/16/2015 19:59:36] Success Display screen: Download Server Script
[08/16/2015 19:59:44] Success Language set: Primary = 9, Secondary = 1
[08/16/2015 19:59:44] Success Display screen: Already At Target
[08/16/2015 19:59:47] Success Run client data event: Client Script
[08/16/2015 19:59:47] Notice Exit update process (Return code: 5)
Attachments
Untitled.png

TempestVVV
Private
Posts: 20
Joined: Mon Aug 17, 2015 7:07 am

Tue Aug 18, 2015 5:07 am

Well I don't expect an owner of the game to reply.
But don't they have a moderator or someone from the company on duty?

Guess it's on vacation autopilot.

User avatar
Durk
Posts: 2224
Joined: Thu Apr 28, 2011 4:36 am
Location: Wyoming

Tue Aug 18, 2015 5:14 am

I see you have been neglected. Makes me sad.

Look here.

http://www.ageod-forum.com/showthread.php?40067-Patch-Problems-Help-requested

Two solutions, one will work

User avatar
arsan
Posts: 6212
Joined: Tue Nov 28, 2006 6:35 pm
Location: Madrid, Spain

Tue Aug 18, 2015 6:39 am

Hi!

Just tried downloading BOR 1.04 patch from this link
http://www.ageod-forum.com/showthread.php?38652-BOR-1-04-patch-available!

And patching my game and i could do it without a problem. It downloaded, extracted and patched up the game ok
I'm using windows 8.1, Firefox, and 7z (freeware compresing program)

So it seems it's not a problem with the patch files, but something on your end. Honestly, i don't know what... maybe some antivirus or the like interfering with the file extracting?

Hope someone can give you better help.

Regards

TempestVVV
Private
Posts: 20
Joined: Mon Aug 17, 2015 7:07 am

Tue Aug 18, 2015 6:58 am

Thanks Durk and Arsan for getting back.
Sorry -none of those solutions worked. I installed this Matrix download on 2 different hard drives on one computer Win7 64 bit and on another computer Win 7 32 bit.
And I get the same decompression error after I update the game via it's update. The patch will not decompress and the U.I. still reads 1.02.

My BoR 1.02 is playable-not crashing. Just doesn't appear to be patched.

All games are set to run in Win 7 compatibility mode on both the 64bit and 32 bit computer.

When I got the WinRAR with the patch on my other computer (downloaded again today)-it was also corrupted and would not extract.

My AntiVirus is Microsoft Essentials and I use Malwarebytes-but those haven't popped up and informed of any problems (like they have with some other game exe.)

Could you try and download the game and install the patch?
Maybe what is online is corrupted.
_____________

I thought maybe my Win7 64 bit computer was the problem. But 2 different computers is...well..I don't have an answer. I have other Matrix/Ageod games and never had any AV problems with them downloading, installing or updating.

______________

Arsan-downloaded it again from the link you provided. It won't come out of the compression-it breaks the operation.
The WinRar program I have works since I opened other game files last night with it.

I'll try downloading on my spare computer with the AV turned off-maybe that is corrupting it.

[ATTACH]34404[/ATTACH]
Attachments
Untitled1.jpg

TempestVVV
Private
Posts: 20
Joined: Mon Aug 17, 2015 7:07 am

Tue Aug 18, 2015 7:35 am

[color="#FFD700"]SUCCESS!!!!!!!![/color]

:thumbsup:

I turned [color="#FF0000"]off[/color] Microsoft Essentials on my spare Win-7 32 Bit computer and the WinRAR opened up as normal and extracted the 1.04 patch. The Patch installed normally.
Evidently Microsoft Essential corrupted every download of this particular patch from the update and Winrar download when it is enabled -but left no indication by popup or log file.. So I guess you can add that to your Help file FAQ/Knowledge base.. I still had Malwarebytes on so I now that wasn't the problem. Thanks both for getting back.



( I don't know how many times a spare computer has helped me-you just can't have one if you turn off AV.)
Attachments
Untitled2.jpg

User avatar
Franciscus
Posts: 4564
Joined: Fri Apr 20, 2007 8:31 pm
Location: Portugal

Tue Aug 18, 2015 9:15 am

Hi

I am moderator of this forum and indeed I am on vacation currently, so I apologize if I didn't answer yesterday.

I am glad you solved your issue. Thanks, Arsan and Durk for your help.

Anyhow your issue is strange...I also use Microsoft Security Essentials (nothing else) and never had a problem with uploading, downloading or decompressing a patch file...
I use 7-zip, by the way.

Regards
[SIGPIC][/SIGPIC]

User avatar
arsan
Posts: 6212
Joined: Tue Nov 28, 2006 6:35 pm
Location: Madrid, Spain

Tue Aug 18, 2015 2:02 pm

Damned antivirus! ;)
Glad you could solve it!

TempestVVV
Private
Posts: 20
Joined: Mon Aug 17, 2015 7:07 am

Tue Aug 18, 2015 3:24 pm

One subtle point.
It's not clear to me if Microsoft Essentials corrupted the downloads on both computers OR disabled the patch file/compressed file once you try to open them -whether compressed or uncompressed.
I do know I had my AV off when I redownloaded the files AND successfully started to install them on both computers.
If any one has this problem that subtle difference;It may not be the downloading that is corrupted-but some process by the AV of the EXECUTION OF OPENING .

Return to “AJE Technical support / Aide technique”

Who is online

Users browsing this forum: No registered users and 1 guest