hattrick
Lieutenant
Posts: 117
Joined: Fri Mar 03, 2006 3:09 am

Tue Oct 05, 2010 11:19 pm

I know there was talk of changing the field artillery in forts to heavy artillery, what was the verdict on this?

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Wed Oct 06, 2010 2:49 am

deleted

hattrick
Lieutenant
Posts: 117
Joined: Fri Mar 03, 2006 3:09 am

Wed Oct 06, 2010 6:40 am

Gray_Lensman wrote:From what I can tell by loading up the (beta 7) 56 to 63 scenario, the artillery in forts is still field artillery NOT heavy artillery.




Thanks Gray.

Does anyone know if they plan on changing this in the future and replacing the field guns with heavy artillery? I know at times field artillery replacements are hard to come by, but that might be historical.

:hat: in advance..

User avatar
Pocus
Posts: 25369
Joined: Wed Oct 19, 2005 7:37 am
Location: Lyon (France)

Wed Oct 06, 2010 8:32 am

Sorry for the bug in construction mode, there will be another release candidate today.
Image


Hofstadter's Law: "It always takes longer than you expect, even when you take into account Hofstadter's law."

User avatar
Pocus
Posts: 25369
Joined: Wed Oct 19, 2005 7:37 am
Location: Lyon (France)

Wed Oct 06, 2010 5:05 pm

Same link, same version, but the bug removed... please download again!
Image


Hofstadter's Law: "It always takes longer than you expect, even when you take into account Hofstadter's law."

User avatar
Ebbingford
Posts: 6093
Joined: Sun Oct 14, 2007 5:22 pm
Location: England

Wed Oct 06, 2010 10:10 pm

Playing as Austria, long campaign.
Still getting the following error messages at end of turn processing, game carries on OK though.

22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 13468 MinDate = 16/09/56
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 13469 MaxDate = 01/12/62
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 13532 MinDate = 16/09/56
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 13533 MaxDate = 01/12/62
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 13548 MinDate = 16/09/56
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 13549 MaxDate = 01/12/62
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 13660 MinDate = 16/09/56
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 13661 MaxDate = 01/12/62
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 13900 MinDate = 16/09/56
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 13901 MaxDate = 01/12/62
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 14156 MinDate = 16/09/56
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 14157 MaxDate = 01/12/62
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 14204 MinDate = 16/09/56
22:02:28 [Error ] FullDebug: Script Engine Error(s), while parsing line 14205 MaxDate = 01/12/62
22:02:28 (Reporting) FullDebug: Script Engine, while parsing line 28516 Unknown Keyword: --------------
22:02:28 [Error ] Errors found in script: 14 Check C:\Program Files\Rise of Prussia\ROP\Scripts\ScriptReport.txt


Script report attached if needed.
Attachments

[The extension txt has been deactivated and can no longer be displayed.]


User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Thu Oct 07, 2010 1:03 am

deleted

User avatar
Charles
Lieutenant
Posts: 146
Joined: Mon Jul 26, 2010 3:22 pm
Location: Canada

Thu Oct 07, 2010 2:04 pm

I installed the latest RC on a clean instal and played 3 turns of the Grand campaign with no technical issues. Options and construction mode work as they should.
[SIGPIC][/SIGPIC]

User avatar
lodilefty
Posts: 7567
Joined: Sat Aug 11, 2007 3:27 pm
Location: Finger Lakes, NY GMT -5 US Eastern

Thu Oct 07, 2010 2:10 pm

Gray_Lensman wrote:Ebbingford (and others who might be interested in some debugging info:

Using the first line of your error messages:



We can look into your posted (linked) ScriptReport.txt to find the following:



Now, we search for the particular event (.sct) file that would contain the specific event referenced above... i.e. evt_nam_PRU_aggro1Bohemia2

Most if not all .sct files reside in the .../Events/... folder in the AGE game system.

So... searching results find that particular event does in fact reside in the PrussianAI.sct event file and has the following syntax:



Not only does the MinDate and MaxDate NOT use the proper format in this particular event (for ROP). It turns out this particular event file is totally screwed up in that most if not all of the other events' MinDate/MaxDate syntax in that same file are also screwed up...

Interesting though... The same types of commands in the AACW event files use the format yyyy/mm/dd. This could be where the mistake was made, presuming that whoever put together these events was used to the previous syntax format. Seems that this was an unnecessary/irrational syntax switch and makes me wonder why, since we are continuously working on what I presumed to be similar event syntax statements for all game designs using the AGE game engine. Going from one AGE game database file to another is going to naturally result in these types of errors when making these types of unnecessary/irrational syntax changes in an event command that is used in all of the AGE games.

Good find... :thumbsup:

Incidentally, had you not posted the ScriptReport.txt file, I would have had to ask for the saved game files in order to rerun the turn to generate that same file for the above debugging work. You did very good in posting the ScriptReport.txt along with your bug report here. Thanks Again. :)

I'm not sure WHO is the end point of contact for ROP database corrections... Not me at this time... BUT whoever is, will obviously need to correct the source database file(s) and regenerate the .sct file(s) for the necessary followup patch. The CSVSplitter.exe file that I have would not output this new syntax correctly anyhow since it does not have a distinction for ROP output files.

To wit:

[ATTACH]12623[/ATTACH]

Notice there is NO distinction for ROP output file extractions in the CSVSplitter that I'm using which is the latest one that modders can download from the Official Files for Modding thread located in the Modding AGE Engine Games SubForum updated June 3rd 2010 per that same thread.

No wonder Modders give up and MOD the text based output files directly when even the volunteer coordinators can't get the latest version of the proper CSVSplitter program. :(


Date format errors are almost always caused by the Excel spreadsheet settings. A "Date" format in the cell will mess up the csv output. I always enter Dates in the correct format by using a ' (single quote) to start the cell. This has always been so, and has nothing to do with the csv splitter, nor should it. It's just 'another of those things' that we learn to work with in order to take advantage of the power of the Excel>csv>splitter method to better track changes and design notes.

You're welcome! :D
Always ask yourself: "Am I part of the Solution?" If you aren't, then you are part of the Problem!
[CENTER][/CENTER]
[CENTER]Visit AGEWiki - your increasingly comprehensive source for information about AGE games[/CENTER]

[CENTER]Rules for new members[/CENTER]
[CENTER]Forum Rules[/CENTER]

[CENTER]Help desk: support@slitherine.co.uk[/CENTER]

User avatar
lodilefty
Posts: 7567
Joined: Sat Aug 11, 2007 3:27 pm
Location: Finger Lakes, NY GMT -5 US Eastern

Thu Oct 07, 2010 3:08 pm

Something really odd here, but first, the facts:

1. The posted csv splitter version 0.71 (June 3, 2010) IS the latest version.
2. The Excel Spreadsheets for these events use correct date format.
3. The message need yyyy.mm.dd or dd/mm/yyyy is in error, as all date formats in RoP and AGE games is yyyy/mm/dd
4. The date formats are correct in every case in the AI files, and are same in other files that I spot checked (Excel and compiled and extracted csv)
5. All these other dates process OK, per the script report posted.

Now, the oddity:

AFAIK, in each case, the date error immediately follows the CheckAILevel = 1 command.

I'll need your saved game that generated the error to test further, before I send a comprehensive bug report to the dev team. After all, developing PoN is their top priority, is it not? :)

Thank you! This is an interesting intellectual challenge!
Always ask yourself: "Am I part of the Solution?" If you aren't, then you are part of the Problem!
[CENTER][/CENTER]

[CENTER]Visit AGEWiki - your increasingly comprehensive source for information about AGE games[/CENTER]



[CENTER]Rules for new members[/CENTER]

[CENTER]Forum Rules[/CENTER]



[CENTER]Help desk: support@slitherine.co.uk[/CENTER]

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Thu Oct 07, 2010 4:32 pm

deleted

User avatar
Generalisimo
Posts: 4176
Joined: Wed Jun 07, 2006 10:03 pm
Location: Buenos Aires, Argentina
Contact: ICQ WLM

Thu Oct 07, 2010 5:12 pm

Gray_Lensman wrote:Interesting... I was assuming that with the implied incorrect format error message, that the problem was caused by having an out of date CSVSplitter, especially since 0.71 has designated buttons for the different AGE engine games but not for ROP where this problem showed up. It just seemed logical that this issue would have been the type of issue to be sorted out/compensated for in the splitter program (by using the game specific buttons) if ROP was expecting a different output syntax format than the other games. Who would expect the .xls (Excel) date format to have to be different for different games in the AGE game system anyway?

Also I could not find the source .xls file for the PrussianAI.sct file in the current ROP_DB.zip file collection to double check the .xls format. Is it included there and I overlooked it, or is it a new file not posted in that grouping?

So the mystery deepens... Why does the ROP engine output error messages that state a different format needed than the other AACW/AGE games?

I really think the error message is wrong. ;)
Even in PON/VGN, all the dates are yyyy/mm/dd.. and in ROP too, just like Steve have said.

Usually, everytime I got that kind of error it was what Steve mentioned... Excel "decided" to change the format to something different before exporting to csv (to the machine system default date format) and so all the dates get mixed up when you apply the CSVSplitter.
Like Steve also mentioned, using the ' character to tell Excel "this is text, not a date" ;) usually solves the problem... but it is not very easy to spot the dates that doesn't have the ' or not... and when you do a copy and paste, Excel automatically removes the '. :blink:
So, for example, in PON for things like the tech tree or the rulers (that have hundreds and hundreds of dates)... the burden to keep adding the ' to the dates is just way too much for me... :neener:
That's why I started using OO to avoid that weird conversion of Excel. :D

Having said all this, it doesn't look like this is the case here, the dates look good in the report... :wacko:
"History is the version of past events that people have decided to agree upon."
Napoleon Bonaparte


BOA-AAR: ¡Abajo el imperialismo Británico! (en español)

AGEOD Facebook Fanpage - news & screenshots about the upcoming games!

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Thu Oct 07, 2010 5:20 pm

deleted

User avatar
Generalisimo
Posts: 4176
Joined: Wed Jun 07, 2006 10:03 pm
Location: Buenos Aires, Argentina
Contact: ICQ WLM

Thu Oct 07, 2010 5:27 pm

Gray_Lensman wrote:Exactly, the dates look identical to all the other games' output files that I've looked thru, Yet there is an error AND the error message states the cause of the error to be a different syntax is required. One can quite easily assume that this was an issue that was supposed to be compensated for in an updated/newer CSVSplitter program.

It'll be interesting to find out the correct source of this error.

That's why I think the error message is misleading... or directly wrong.

I do not have the files here, just the ones reported by Ebb.... look at this event:
Line 12310: SelectFaction, selected: Prussia
Line 12311: Started processing event: evt_nam_PRU_Leader_AIActivate
Line 12311: This event is not yet referenced, base number of allowed occurences 999
Line 12314: Min date evaluated: 1756/01/01 converted to turn 3745 current turn 3762 True
Line 12316: CheckAILevel: Checking AI Level of faction Prussia at least equal to 1 True

Line 12317: ActorEnabled : False
Line 12325: Finished processing event: evt_nam_PRU_Leader_AIActivate

No error reported.

Another one:
Line 12973: SelectFaction, selected: Austria
Line 12974: Started processing event: evt_nam_AUS_Leader_AIActivate
Line 12974: This event is not yet referenced, base number of allowed occurences 999
Line 12977: Min date evaluated: 1756/01/01 converted to turn 3745 current turn 3762 True
Line 12979: CheckAILevel: Checking AI Level of faction Austria at least equal to 1 False

Line 12988: Finished processing event: evt_nam_AUS_Leader_AIActivate

Again, no error.

Now look at one with the error:
Line 13460: SelectFaction, selected: Prussia
Line 13461: Started processing event: evt_nam_PRU_aggro1Bohemia2
Line 13461: This event is not yet referenced, base number of allowed occurences 999
Line 13464: TurnIndex: Testing 17 vs current turn index: 17 True
Line 13465: Probability evaluated: Probability 10 rolled 10 True
Line 13467: CheckAILevel: Checking AI Level of faction Prussia at least equal to 1 True
Line 13468: => CheckMinDate command, Erroneous format for date, need yyyy.mm.dd or dd/mm/yyyy
Line 13469: => CheckMaxDate command, Erroneous format for date, need yyyy.mm.dd or dd/mm/yyyy

Line 13471: Entering triggered actions for event evt_nam_PRU_aggro1Bohemia2
Line 13472: AI.ChgAggro Prussia Aggressivity coeff in Theater 73 is now at 90
Line 13474: Finished processing event: evt_nam_PRU_aggro1Bohemia2


Maybe that's the source of the problem?... all the events that report an error, have the CheckAILevel before the date.
"History is the version of past events that people have decided to agree upon."
Napoleon Bonaparte




BOA-AAR: ¡Abajo el imperialismo Británico! (en español)



AGEOD Facebook Fanpage - news & screenshots about the upcoming games!

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Thu Oct 07, 2010 5:30 pm

deleted

User avatar
lodilefty
Posts: 7567
Joined: Sat Aug 11, 2007 3:27 pm
Location: Finger Lakes, NY GMT -5 US Eastern

Thu Oct 07, 2010 5:47 pm

Hope that's it... saved game will allow me to continue to test :)

While waiting, I found that in WIA with latest beta 108RC6, a MinDate immediately following a CheckAILevel = 1 processd OK, so this may get wierder (more wierd? Wierderer?) :blink:

Patience shall be rewarded... :)
Always ask yourself: "Am I part of the Solution?" If you aren't, then you are part of the Problem!
[CENTER][/CENTER]

[CENTER]Visit AGEWiki - your increasingly comprehensive source for information about AGE games[/CENTER]



[CENTER]Rules for new members[/CENTER]

[CENTER]Forum Rules[/CENTER]



[CENTER]Help desk: support@slitherine.co.uk[/CENTER]

User avatar
Clovis
Posts: 3222
Joined: Wed Nov 09, 2005 7:43 pm
Location: in a graveyard
Contact: Website

Thu Oct 07, 2010 10:20 pm

Ebbingford wrote:Playing as Austria, long campaign.
Still getting the following error messages at end of turn processing, game carries on OK though.



Script report attached if needed.


Hi,

You should do a fresh install of ROP before applying the patch. You have certainly installed some weeks ago the provisional events file I've uploaded in tis thread for the Prussian AI. As the current patch has moved this events to a new file, the old modded file hasn't been replaced.

I've myself no error with the last patch. THERE IS NO PROBLEM with the AGE engine itself or the last Prussian AI version. sorry for the inconvenience.
[LEFT]Disabled
[CENTER][LEFT]
[/LEFT]
[LEFT]SVF news: http://struggleformodding.wordpress.com/

[/LEFT]
[/CENTER]



[/LEFT]

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Thu Oct 07, 2010 10:54 pm

deleted

Baris
AGEod Guard of Honor
Posts: 1913
Joined: Fri Apr 16, 2010 9:50 pm

Thu Oct 07, 2010 11:21 pm

In my game as Austria against AI Prussia it is turn 26 and everything is working nicely.. Other than that:

French Chevert attacking from Homburg to Frankfurt Am Main, There is a river between but I didnt get penalty for river crossing. All directions was showing brown.

Daun achieved breach 3 in Dresden, but when he assaulted he ended up with breach 4 in message log I captured the fort battery inside the structure but I wasnt able to capture Dresden :) (can post save game if necessary)

Elite infantry is maybe training fast. Mostly they are not fighting. in one turn I got 15 notification about trained to Elite status.

Fort Batteries are using field artilery. Maybe without changing the the whole system in Ageod games there can be some "replacements after construction of units" like infantry depots for normal field artilery.

User avatar
Ebbingford
Posts: 6093
Joined: Sun Oct 14, 2007 5:22 pm
Location: England

Thu Oct 07, 2010 11:57 pm

Ok, here's what I've done.

After initially just downloading the 1.03b7, 6th October, and then just applying it I received the error messages in my post above at end of turn 1 processing, playing as Austria, long campaign. Here are the saves from that game, (Game1)

I then uninstalled, deleted all remaining folders, emptied my recycle bin, ran c-cleaner and its registry cleaning thingy, and then rebooted my computer. Then reinstalled RoP and then patched to 1.03b7. I then had the following error messages at end of turn 1 processing, again playing as Austria, long campaign.
23:44:45 [Error ] FullDebug: Script Engine Error(s), while parsing line 13484 MinDate = 16/09/56
23:44:45 [Error ] FullDebug: Script Engine Error(s), while parsing line 13485 MaxDate = 01/12/62
23:44:45 [Error ] FullDebug: Script Engine Error(s), while parsing line 13500 MinDate = 16/09/56
23:44:45 [Error ] FullDebug: Script Engine Error(s), while parsing line 13501 MaxDate = 01/12/62
23:44:45 [Error ] FullDebug: Script Engine Error(s), while parsing line 13724 MinDate = 16/09/56
23:44:45 [Error ] FullDebug: Script Engine Error(s), while parsing line 13725 MaxDate = 01/12/62
23:44:45 [Error ] FullDebug: Script Engine Error(s), while parsing line 13788 MinDate = 16/09/56
23:44:45 [Error ] FullDebug: Script Engine Error(s), while parsing line 13789 MaxDate = 01/12/62
23:44:45 [Error ] FullDebug: Script Engine Error(s), while parsing line 13868 MinDate = 16/09/56
23:44:45 [Error ] FullDebug: Script Engine Error(s), while parsing line 13869 MaxDate = 01/12/62
23:44:45 (Reporting) FullDebug: Script Engine, while parsing line 28516 Unknown Keyword: --------------
23:44:45 [Error ] Errors found in script: 10 Check C:\Program Files\Rise of Prussia\ROP\Scripts\ScriptReport.txt


Here is the script report and save game from this effort, (Test).
Attachments
Test.rar
(648.58 KiB) Downloaded 106 times
Game1.rar
(683.49 KiB) Downloaded 124 times

User avatar
Franciscus
Posts: 4571
Joined: Fri Apr 20, 2007 8:31 pm
Location: Portugal

Fri Oct 08, 2010 12:22 am

Just a quick test, 2 small bugs:

- the battle circle animation does not show (ie, the red-green animation during battles). Is this wad ?? (I seem to remember reading about this a few time ago... :p apy:?)
- a small graphic glitch in the unit panel (maybe related to screen resolution: 1920x1080) - see pic.

Regards
Attachments
small graphic glitch.JPG
[SIGPIC][/SIGPIC]

User avatar
Franciscus
Posts: 4571
Joined: Fri Apr 20, 2007 8:31 pm
Location: Portugal

Fri Oct 08, 2010 12:58 am

As to Ebbingford's reported errors, I am unable to reproduce them...(Austria, 1st turn, long campaign)... :blink:

I have NOT made a clean install yet, I did apply 1.02 a few months ago and then a couple of the beta 1.03s, but have never played much. I DID never apply any of the Clovis AI quickfixes, though.

Regards
[SIGPIC][/SIGPIC]

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Fri Oct 08, 2010 2:13 am

deleted

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Fri Oct 08, 2010 5:05 am

deleted

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Fri Oct 08, 2010 11:43 am

deleted

User avatar
lodilefty
Posts: 7567
Joined: Sat Aug 11, 2007 3:27 pm
Location: Finger Lakes, NY GMT -5 US Eastern

Fri Oct 08, 2010 1:05 pm

Gray_Lensman wrote:Here's another idea that has worked in the past

Has anyone thought to go into the PrussianAI.sct file or source DB file and switch the conditions orders to have the CheckAILevel condition follow the MaxDate and MinDate conditions?


_______________________________________

Sent from my Droid X using Swype.


That's my next thing to try. Stay tuned ;)
Always ask yourself: "Am I part of the Solution?" If you aren't, then you are part of the Problem!
[CENTER][/CENTER]

[CENTER]Visit AGEWiki - your increasingly comprehensive source for information about AGE games[/CENTER]



[CENTER]Rules for new members[/CENTER]

[CENTER]Forum Rules[/CENTER]



[CENTER]Help desk: support@slitherine.co.uk[/CENTER]

User avatar
lodilefty
Posts: 7567
Joined: Sat Aug 11, 2007 3:27 pm
Location: Finger Lakes, NY GMT -5 US Eastern

Solution = mindate errors

Fri Oct 08, 2010 2:12 pm

Hah!

Whatta challenge.

Turns out that:
  1. the Prussian AI stuff is also imbedded in the ROP Options AI.sct, with incorrect date functions. :bonk:
  2. the PrusianAI.sct is not even referenced, so editing it makes no difference :blink:


Once I tested using only the newer PrusianAI.sct, all is well! :thumbsup:

I will fix this and post a HotFix as soon as I'm sure I've got the latest DB files involved....

For want of a nail...... :D
Always ask yourself: "Am I part of the Solution?" If you aren't, then you are part of the Problem!
[CENTER][/CENTER]

[CENTER]Visit AGEWiki - your increasingly comprehensive source for information about AGE games[/CENTER]



[CENTER]Rules for new members[/CENTER]

[CENTER]Forum Rules[/CENTER]



[CENTER]Help desk: support@slitherine.co.uk[/CENTER]

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Fri Oct 08, 2010 2:26 pm

deleted

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Fri Oct 08, 2010 2:29 pm

deleted

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Fri Oct 08, 2010 2:48 pm

deleted

Return to “Help to improve RoP”

Who is online

Users browsing this forum: No registered users and 3 guests