Page 1 of 1

The Application was unable to start correctly (0xc0000005)

Posted: Tue Jul 23, 2013 6:46 am
by Massu
I just bought and installed RoP Gold from Matrix Games today, and was dismayed to find that it will not run after seemingly installing properly. After a short load time I receive this error message "The Application was unable to start correctly (0xc0000005)". This happens every time I attempt to start it. Interestingly, the "PLAY" button on the autorun screen doesn't seem to do anything and I only get this error attempting to run the game's .exe from the folder itself. Not sure if that's relevant. Google tells me I must be the only person in the world having this specific issue with RoP.

I should add that I've completely uninstalled it (I even removed every reference to it from my registry) and also tried installing it to a non-default folder in my C: drive, as is recommended all the time for RoP.

I can't fathom what else could be wrong. I've rebooted several times, attempted to run (and even install it) as an administrator, tried compatibility modes etc all to no avail.

I'm running Win7X64.

Here's my DxDiag report. I have no clue what the problem is but I'm pretty frustrated. While I know this error is often associated with RAM problems, I doubt that's the issue because I've had 0 problems running any other software as recently as just now, including games.



Posted: Tue Jul 23, 2013 8:22 am
by Massu
At this point my gut feeling is that there's something wrong with the file on Matrix's end, as in some part of it (say, ROP.exe) is corrupt. I can't think of anything else. I even went through the whole production of checking for rootkits with rkill and tdss to zero result.

I'm giving up for the night.

Posted: Tue Jul 23, 2013 2:01 pm
by Pocus
Can you check with Matrix support? I can provide you with an email if need be.

Posted: Tue Jul 23, 2013 4:12 pm
by Massu
I opened a ticket last night and just pasted in what I've posted here. Their first attempted solution was to have me update my video drivers. Did so and rebooted and no joy, same error. Given that RoP was first published in 2009, I think, I kinda doubted that was going to have much effect in the first place.

This is really frustrating, especially considering that no one else seems to be having the same issue.

Posted: Tue Jul 23, 2013 9:23 pm
by Massu
Well I just discovered something that might help narrow the problem down: This is only occurring with AGE engine games. I've had Revolution Under Siege installed and working for some time and it now gives me the same exact error as RoP is. By contrast, Unity of Command, Harpoon Commanders Edition, and my steam library games all start and work fine. Is there anything in particular that conflicts with launching AGE engine titles? I've even gone so far as uninstalling my virus scanners and shutting off my firewall, no joy.

Posted: Wed Jul 24, 2013 1:12 am
by Massu
Fixed it. (Got sick of waiting for Matrix). It was DEP. I created an exception for RUS and it ran... so I reinstalled ROP and did the same, and it's running as we speak. Might want to hang onto this tidbit for anyone with the same issue in the future!

Posted: Wed Jul 24, 2013 4:25 pm
by Pocus
An exception at which level? Anti virus? Which one you use? Norton, Kapersky?

Posted: Thu Jul 25, 2013 9:20 pm
by Massu
Sorry. To clarify, I made exceptions for the .exes in Data Execution Prevention. It was never my Anti-Virus that was the issue (I use AVG). DEP apparently doesn't play well with your executables, no idea why.