Posts: 9
Joined: Mon Jun 16, 2014 4:31 am

Help Getting 1.08q working.

Mon Jun 16, 2014 4:45 am

Hello. I hope some people still read this forum since I'm in need of assistance.

I have the gamersgate version of WWI gold where I think the last patch they provided may be 1.08l.

I would very much like to get version 'q' working but I am experiencing numerous ctd.

After browsing the forum I read about disabling UAC. I managed to do that and installed the patch. When i started the game it says that I am running 1.08q. Everything seems to work fine until I get to the battle resolution during the military phase. After fighting a few battles I will almost always crash to desktop. It is impossible for me to get more than a few turns into the game before I crash.

When I crash I will sometimes see an error message saying :

debug assertion failed!
Program c:\ProgramFiles(x86)\World War one Gold\ww1.exe
File dbgdel.cpp
Line 52
Expression -BLOCK-TYPE-IS-VALID(pHead -> nBlock use)

For more information on how your program can cause an assertion failure, see the visual c++ documentation on asserts.

I have two computers, a desktop and a laptop. The laptop runs Windows 7 and the desktop runs windows 8 and I have had the same problem and message on both computers when I tried to use 1.08q.

I tried browsing through the forum but I could not find anyone who seemed to have a similar problem. I was wondering if anyone knew how I could resolve this. 1.08l seems pretty stable but I would like to get the last patch up and working.

User avatar
Posts: 1481
Joined: Wed Nov 30, 2005 10:51 am

Mon Jun 16, 2014 2:35 pm


This does sound odd. Running a GG version should cause no such problem as far as I am aware.

It is probably not the reason, but have you tried right-clicking the game's start icon and choose "run as administrator?" also first try that with the patch itself when applying it, but then again, with UAC turned off this shouldn't be an issue.

Posts: 9
Joined: Mon Jun 16, 2014 4:31 am

Tue Jun 17, 2014 7:37 am

I think I got it working on my laptop. It is running pretty smoothly wit very few crashes. In case anyone else has a similar problem, all I did was go into the WWI folder and click the batch file instead of the exe file to start the game. That seems to have done the trick.

User avatar
Posts: 4679
Joined: Mon Dec 19, 2005 4:52 pm
Location: Italy
Contact: Website

Tue Jun 17, 2014 11:35 am

That means you are running the game in single-core mode.
Visit my other games at :

Return to “WW1 Technical support / Aide technique”

Who is online

Users browsing this forum: No registered users and 1 guest