User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Tue Oct 30, 2007 2:26 am

deleted

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Thu Nov 29, 2007 10:20 pm

deleted

User avatar
Pocus
Posts: 24756
Joined: Wed Oct 19, 2005 7:37 am
Location: Lyon (France)

Fri Nov 30, 2007 11:13 am

Use Save As, not Export. With Save as you have the option to save in CSV (save in XLS before, because the document will be converted).
Image


Hofstadter's Law: "It always takes longer than you expect, even when you take into account Hofstadter's law."

Guru80
Colonel
Posts: 311
Joined: Tue Oct 02, 2007 5:34 am

Fri Nov 30, 2007 7:43 pm

It appears that image for Filter settings is from Open Office. When you select Save As and choose CVS from the drop down menu it offers a check box under the file name called Change Filter Settings which you can select to bring up the screen you posted above on the bottom. Not sure how to do it in Office but from what I hear it is more straight forward in Open Office since it is right there.

I use Open Office and below is my saving process:

What I always do to ensure I have an updated XLS and CSV file is I will:
Save As...,
Select CVS from the drop down list,
Click on the option box for Edit Filter Settings on the bottom,
Click Save (after entering your filename. I always make it different from the default file you are working on and save the XLS and CVS file as the same name),
Leave Character Set alone, Change Field Delimiter to semi-colon ( ; ), delete the Text Delimiter so it is blank, leave the check boxes alone, click OK and it will save as the CVS file.

I IMMEDIATELY than click Save As, select XLS from the drop down for the most current version of MS Office, and save it as the same name as above but with the xls extention (it won't overwrite the other since they are different file types.)

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Fri Nov 30, 2007 10:34 pm

deleted

User avatar
Gray_Lensman
Posts: 497
Joined: Mon Jun 18, 2007 4:04 am
Location: Who is John Galt?

Fri Nov 30, 2007 11:15 pm

deleted

User avatar
Pocus
Posts: 24756
Joined: Wed Oct 19, 2005 7:37 am
Location: Lyon (France)

Tue Dec 18, 2007 3:27 pm

Updated with NC database.
Image


Hofstadter's Law: "It always takes longer than you expect, even when you take into account Hofstadter's law."

Lafrite
Posts: 842
Joined: Mon Nov 14, 2005 9:00 pm
Contact: Website

Tue Dec 18, 2007 4:08 pm

Pocus wrote:Updated with NC database.


Arnaque, le lien NPC donne sur le fichier ACWDB :siffle:

User avatar
Pocus
Posts: 24756
Joined: Wed Oct 19, 2005 7:37 am
Location: Lyon (France)

Tue Dec 18, 2007 5:12 pm

retapé à la main, ca devrait fonctionner.
Image


Hofstadter's Law: "It always takes longer than you expect, even when you take into account Hofstadter's law."

heywheresmysnack
Conscript
Posts: 8
Joined: Sun Jul 15, 2007 2:29 am

Mon Apr 14, 2008 12:02 pm

I have no clue what I'm doing. I'm trying to modify how much money the CSA get at the start of the game. I've gotten the files and the splitter and found where to edit it, but after that, I have no clue what I'm doing.

I can save as a CSV after altering the file, but after that... nothing.

User avatar
Primasprit
Posts: 1614
Joined: Mon Jun 19, 2006 7:44 pm
Location: Germany

Mon Apr 14, 2008 2:19 pm

Hi heywheresmysnack!

Please take a look to this post: http://www.ageod-forum.com/showpost.php?p=30711&postcount=16

It describes how to create a new scenario after some modifications. Obviously you don't need the stuff about the cities file but the rest should help you learning the procedure xls -> csv -> script -> scenario.

Good luck! :p

Cheers
Norbert

User avatar
squarian
Brigadier General
Posts: 481
Joined: Thu Aug 07, 2008 7:41 pm
Location: Pittsburgh, Pennsylvania

Mon Sep 12, 2011 3:16 pm

Guru80 wrote:Leave Character Set alone, Change Field Delimiter to semi-colon ( ; ), delete the Text Delimiter so it is blank, leave the check boxes alone, click OK and it will save as the CVS file.


Newb first attempt here - I've d/ld OpenOffice.org 3.3.0, which appears to be latest version on OpenOffice website.

My steps:

Open xls file, make change, click "save as".

Select "text csv" (which is the only csv option listed in dropdown menu)

Select "edit filter settings"

Click "save"

Dialogue box appears ("Export of text files") with a preset character set (Western Europe Windows-1252/WinLatin1) and dropdown menus for field delimiter and text delimiter.

I set field delimiter to semicolon ( ;) .

I pull down text delimiter looking for "none/blank" - and here's the glitch - the only options on this list are single quote mark (') or double quote mark (").

Per AgeWiki instructions, none/blank is necessary - but where is it? Help?

User avatar
lodilefty
Posts: 7372
Joined: Sat Aug 11, 2007 3:27 pm
Location: Finger Lakes, NY GMT -5 US Eastern

Mon Sep 12, 2011 4:49 pm

squarian wrote:Newb first attempt here - I've d/ld OpenOffice.org 3.3.0, which appears to be latest version on OpenOffice website.

My steps:

Open xls file, make change, click "save as".

Select "text csv" (which is the only csv option listed in dropdown menu)

Select "edit filter settings"

Click "save"

Dialogue box appears ("Export of text files") with a preset character set (Western Europe Windows-1252/WinLatin1) and dropdown menus for field delimiter and text delimiter.

I set field delimiter to semicolon ( ;) .

[color="red"]I pull down text delimiter looking for "none/blank" - [B]and here's the glitch - the only options on this list are single quote mark (') or double quote mark ("). [/color][/B]

Per AgeWiki instructions, none/blank is necessary - but where is it? Help?


Almost there! I too use Open Office. :thumbsup: :love:

In the text delimiter box, highlight the [color="Red"]"[/color] and press your [color="red"]<delete>[/color] key.
:D
Always ask yourself: "Am I part of the Solution?" If you aren't, then you are part of the Problem!
[CENTER][/CENTER]
[CENTER]Visit AGEWiki - your increasingly comprehensive source for information about AGE games[/CENTER]

[CENTER]Rules for new members[/CENTER]
[CENTER]Forum Rules[/CENTER]

[CENTER]Help desk: support@slitherine.co.uk[/CENTER]

User avatar
lukasberger
AGEod Veteran
Posts: 782
Joined: Thu Dec 07, 2006 5:59 pm

Sun Sep 18, 2011 9:07 pm

I'm trying to work with the PON models and units data I got from McNaughton and running into some trouble. I open the VGN_DB_Models_37b.xls file in Open Office and follow the steps above including changing the filter settings as indicated (although using , as field delimiter since using ; gave me an error).

Then I go into the splitter select the csv and output paths, select the VGN and mdl tabs under convert data, hit convert and get the error message:

Exception in line 0,-,CMN_Erroneous,... etc.

Can anyone let me know what I'm doing wrong

User avatar
PhilThib
Posts: 13416
Joined: Tue Oct 18, 2005 5:21 pm
Location: Meylan (France)

Mon Sep 19, 2011 7:42 am

Those files are extremely hard to handle and huge, and prone to generate errors...

Here is the trick(s) I use when I create the CSV version from Excel (I don't use open office).

* First destroy all comments columns (those with a § in the header)
* destroy all columns after the last
* save as CSV
* re-open the CSV, and then again destroy all columns to the right of the last one
* save, and then only proceed to the splitter...

The reason of all this is linked to some unknown and invisible caracters that are leftover somwhere in the excel and creating havoc in the process, by destroying everything not useful you kind of avoid it...

:bonk:
Image

User avatar
lukasberger
AGEod Veteran
Posts: 782
Joined: Thu Dec 07, 2006 5:59 pm

Mon Sep 19, 2011 11:33 am

Thanks. I'll give that a try later and see how it goes :thumbsup:

User avatar
lukasberger
AGEod Veteran
Posts: 782
Joined: Thu Dec 07, 2006 5:59 pm

Tue Sep 20, 2011 9:45 am

I tried using that trick (in excel this time) but ended up with the same error message. There must be something else I'm doing wrong. I'll have to experiment further :bonk:

User avatar
PhilThib
Posts: 13416
Joined: Tue Oct 18, 2005 5:21 pm
Location: Meylan (France)

Tue Sep 20, 2011 9:53 am

If you can't move forward, send me your Excel file (not the CSV) to pthibaut@ageod.net and I'll try to find out what happens... :confused:
Image

User avatar
lukasberger
AGEod Veteran
Posts: 782
Joined: Thu Dec 07, 2006 5:59 pm

Tue Sep 20, 2011 10:01 am

OK. Thanks Phil. I'll try to mess around with it some more first. Having had some experience with files and convertors that crash if you even look at them wrong, I've learned that patience and persistence are the most important things.

User avatar
lukasberger
AGEod Veteran
Posts: 782
Joined: Thu Dec 07, 2006 5:59 pm

Sat Feb 04, 2012 8:11 pm

Sorry guys, I'm still having some problems. For one reason or another I haven't worked with PON modding for a while but I'm now hoping to get going again. Unfortunately I'm still unable to get the splitter to work on the models file correctly, even while following PhilThib's directions and using a copy of the default models file that I haven't edited at all.

Here's what I do:
* I open the VGN_DB_Models_37h.xls in either excel or open office (it doesn't seem to matter which I use).
* I destroy all comments columns (those with a § in the header)
* I destroy all columns after the last (the blank columns)
* save as CSV, following to the letter the instructions in this post
* re-open the CSV, and then again destroy all columns to the right of the last one (blank ones again)
* save, and then only proceed to the splitter...
* In splitter I then set the input and output paths
* go to the convert data tab and click the little mdl button
* change the values in column(s) used for file name to 3
* keep all the other values the same including column used for alias at 4. (although I don't actually know if ( = )is the correct value for the key to value separator line so I've used that, also ( , ) and just left it blank, none of which seems to make any difference)
* hit convert:

In the models folder all that's created is one file named .mdl with a size of 0 bytes and an incorrectly setup mdl_Alias.ini that's nearly 18 mb's large, contains all the data from the .csv and where the lines look like this:

$ = 1,-,CMN_Mch,mdl_CMN_Mch,CMN,Shipping Asset,NULL,Shipping Trs.,$mdl_txt_CMN_Mch,$famTransportShip,symbol_tra nsport.png,$sizNatoSqd,$colGray64,ENG,mdl_CMN_Tran sport1.png,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0 ,0,0,0,0,0,0,0,0,0,0,NULL,NULL,NULL,NULL,NULL,NULL ,NULL,NULL,NULL,NULL,50,1,4,8,NULL,2,25,0,0,0,0,0, 2,75,$AllWater,100,30,20,7,7,2,2,0,3,0,10,0,1,2,-1,NULL,1,NULL,NULL,10,1,0,100,0,100,0,0,1,0,25,75, *CommerceShip* 1,$abiTransport10,NULL,NULL,NULL,NULL,NULL,NULL,NU LL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,0, 0,0,0,0,0,0,0,0,0,0,90,NULL,NULL,NULL,NULL,NULL,NU LL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NU LL,NULL,NULL,NULL,NULL

instead of like this:
$mdl_CMN_Mch = 1

I figured there's no point in sending Phil a copy of my excel file since right now I'm just using the default models file. Clearly I'm doing something, or several things, wrong but am unable to figure out what. Some more help would be much appreciated.

Thanks,
Lukas

User avatar
lukasberger
AGEod Veteran
Posts: 782
Joined: Thu Dec 07, 2006 5:59 pm

Sat Feb 04, 2012 8:35 pm

I've made some progress. I removed all other files from the folder that the csv was in and followed the same instructions and am getting a different result now.

I get no error message any more but in the models folder all that's created is one file named .mdl with a size of 0 bytes and an incorrectly setup mdl_Alias.ini that's nearly 18 mb's large, contains all the data form the .csv and where the lines look like this:

$ = 1,-,CMN_Mch,mdl_CMN_Mch,CMN,Shipping Asset,NULL,Shipping Trs.,$mdl_txt_CMN_Mch,$famTransportShip,symbol_transport.png,$sizNatoSqd,$colGray64,ENG,mdl_CMN_Transport1.png,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,50,1,4,8,NULL,2,25,0,0,0,0,0,2,75,$AllWater,100,30,20,7,7,2,2,0,3,0,10,0,1,2,-1,NULL,1,NULL,NULL,10,1,0,100,0,100,0,0,1,0,25,75,*CommerceShip* 1,$abiTransport10,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,0,0,0,0,0,0,0,0,0,0,0,90,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL

So that's progress, I guess, but I'm still some way from the desired result.

User avatar
lukasberger
AGEod Veteran
Posts: 782
Joined: Thu Dec 07, 2006 5:59 pm

Sat Feb 04, 2012 9:23 pm

I also tried this with the units file, the merchandises file and several others and am getting the exact same results. So clearly the problem is with me, I just can't figure out what it is :bonk:

User avatar
lodilefty
Posts: 7372
Joined: Sat Aug 11, 2007 3:27 pm
Location: Finger Lakes, NY GMT -5 US Eastern

Sat Feb 04, 2012 11:49 pm

[B]CRITICAL NOTE:
[/B]
When exporting the csv files, you must define the “Field Delimiter" as a semicolon [B]; and the 'text delimiter' as [/B]
[B]none or blank. [these are the English language terms from Open Office©] [/B]

This is absolutely required for ALL files from the spreadsheet DB being prepared for use
[Models, Units, weathers, abilities, etc.], not just scenarios.

;

http://www.ageod.net/agewiki/Csv_splitter
Always ask yourself: "Am I part of the Solution?" If you aren't, then you are part of the Problem!
[CENTER][/CENTER]

[CENTER]Visit AGEWiki - your increasingly comprehensive source for information about AGE games[/CENTER]



[CENTER]Rules for new members[/CENTER]

[CENTER]Forum Rules[/CENTER]



[CENTER]Help desk: support@slitherine.co.uk[/CENTER]

User avatar
lukasberger
AGEod Veteran
Posts: 782
Joined: Thu Dec 07, 2006 5:59 pm

Sun Feb 05, 2012 1:52 am

Thanks a ton lodilefty. Stupid of me.

I knew that but since I'd been getting an error message in the past when using a semi-colon as field-delimiter before I thought that I should be using a comma. With a little experimentation I found out out that the error message actually related to not having deleted all of the blank columns. So it works now :thumbsup:

User avatar
Franciscus
Posts: 4564
Joined: Fri Apr 20, 2007 8:31 pm
Location: Portugal

Sun Apr 01, 2012 9:54 am

Hello guys.

Regarding CSV files, are you using Openoffice or LibreOffice ?

I tried Excel, but could not find a way to configure adequately the CSV exporting options...

User avatar
lodilefty
Posts: 7372
Joined: Sat Aug 11, 2007 3:27 pm
Location: Finger Lakes, NY GMT -5 US Eastern

Sun Apr 01, 2012 12:04 pm

Franciscus wrote:Hello guys.

Regarding CSV files, are you using Openoffice or LibreOffice ?

I tried Excel, but could not find a way to configure adequately the CSV exporting options...


I use OO, but beware of very very long text strings in a single cell, as there is a limit that can "silently" truncate the text....
...I simply try to shorten the text!

...I havent used Excel since I retired [2005], but I'm pretty sure there is a way to configure, as often the final LocalStrings files must be done with Excel...
Always ask yourself: "Am I part of the Solution?" If you aren't, then you are part of the Problem!
[CENTER][/CENTER]

[CENTER]Visit AGEWiki - your increasingly comprehensive source for information about AGE games[/CENTER]



[CENTER]Rules for new members[/CENTER]

[CENTER]Forum Rules[/CENTER]



[CENTER]Help desk: support@slitherine.co.uk[/CENTER]

User avatar
PhilThib
Posts: 13416
Joined: Tue Oct 18, 2005 5:21 pm
Location: Meylan (France)

Mon Apr 02, 2012 7:43 am

Using Excel since the beginning (the same good old 2003 version), I did not configure any option, just use "Save As..." and choose CSV format...works perfect in 99% of cases...
Image

User avatar
Franciscus
Posts: 4564
Joined: Fri Apr 20, 2007 8:31 pm
Location: Portugal

Mon Apr 02, 2012 8:15 am

Thanks.
I am no excel expert, but I have the 2010 version, it seems a very different beast from previous versions...
OO 3.2 seems to work ok so maybe I will stick with it

Regards

Return to “Modding AGE engine games”

Who is online

Users browsing this forum: No registered users and 2 guests